Friday, 10 July 2020

WARNING: Unable to raise nofile/nproc limit to 64000. Ops Manager may not function correctly.


Warning:

WARNING: Unable to raise nofile limit to 64000. Ops Manager may not function correctly.
WARNING: Unable to raise nproc limit to 64000. Ops Manager may not function correctly.


Solution: 

Add below lines to file /etc/security/limits.d/20-nproc.conf  


mongo     soft    nproc   2047
mongo     hard    nproc   64000
mongo     soft    nofile  4096
mongo     hard    nofile  65536
mongo     soft    stack   10240

Note: here mongo is my os user from which i am installing ops manager.

[mongo@opsmanager bin]$ cat  /etc/security/limits.d/20-nproc.conf
# Default limit for number of user's processes to prevent
# accidental fork bombs.
# See rhbz #432903 for reasoning.

*          soft    nproc     64000
root       soft    nproc     unlimited
mongo     soft    nproc   2047
mongo     hard    nproc   64000
mongo     soft    nofile  4096
mongo     hard    nofile  65536
mongo     soft    stack   10240

No comments:

Post a Comment

Login to the database as user C##GGUSER failed because of error Error while trying to retrieve text for error ORA-01804.

 Error :  2026-09-19 11:28:18  ERROR   OGG-00303  Unable to connect to database using user C##GGUSER@CDB. Ensure that the necessary privileg...