Sunday, 22 June 2025

The instance '****.**.**:3306' cannot be added to an InnoDB cluster because it has asynchronous (source-replica) replication channel(s) configured. MySQL InnoDB Cluster

  Error: 

  MySQL  JS > dba.checkInstanceConfiguration("root@192.*.*.*")

 NOTE: Found unexpected replication channel '' at ****.**.**:3306:3306

WARNING: The instance '****.**.**:3306' cannot be added to an InnoDB cluster because 

it has asynchronous (source-replica) replication channel(s) configured. MySQL InnoDB Cluster 

does not support manually configured channels as they are not managed using the AdminAPI (e.g. when PRIMARY moves to another member)

which may cause cause replication to break or even create split-brain scenarios (data loss).

Solution: 

         mysql> STOP REPLICA;

mysql> RESET REPLICA  ALL;

RE-execute : 

           MySQL  JS > dba.checkInstanceConfiguration("root@192.168.94.133")

No comments:

Post a Comment

Login to the database as user C##GGUSER failed because of error Error while trying to retrieve text for error ORA-01804.

 Error :  2026-09-19 11:28:18  ERROR   OGG-00303  Unable to connect to database using user C##GGUSER@CDB. Ensure that the necessary privileg...